Jump to content

Archived

This topic is now archived and is closed to further replies.

JerryJV

Problems reloading Combat

Recommended Posts

hcmlogging20160912122207.txtHello,
 
Purchased, downloaded and installed HCM on a Window's 10 machine.  Exported about 18 characters.  All seemed to work.
 
Initial loading of the characters work without any problems.  I am trying to practice using the program to be able use to handle combat for our game.
 
If I save the combat before making any attack, the program will reload without any problem.  If I start any combat, then save the combat, the combat will reload.
 
The error is that there is a null in ATPOWERS
 
Has anyone else seen this? 
 
I'm including the files, I will do so again on the feedback page from the manual

 

Jerry

Practice 4 c.xml

Black Guardian Old Man.XML

Boulder.XML

EarthWindAndFire 1.XML

Characters.zip

Share this post


Link to post
Share on other sites

Thank you for purchasing HCM. 

 

A quick look at the posted XML files (thank you very very much for that) has shown me where the problem is.  I should be able to fix this quickly and do some testing.  Getting a new version on line takes a bit of time.  I am dependent on when Jason can post things into the store. 

Share this post


Link to post
Share on other sites

You are welcome.....

 

Hope it isn't a major problem.  Are you going to share?  I'd like to understand where the problem is.

 

Thanks,

 

Jerry

 

The problem is minor based on what I am seeing.  There is a XML tag Practice 4 c.xml file "<POWERS>" which should really be "<ATPOWERS>".  This tells me I forgot to change one of the places where the tags get written out when HCM saves the combat file.

Share this post


Link to post
Share on other sites

Ok here is what I did to test the problem you reported:

 

  1. Unzipped the three characters.
  2. Opened them in the current version of HD6
  3. Noticed they are 5e characters
  4. Used the 5e Combat Export (sorry about the title being screwy on that)
  5. Loaded the combat export XML file into HCM
  6. Each character was loaded as an NPC
  7. Picked move for each character until I got to Turn 1 Phase 6
  8. Did a Save As and gave the resulting XML file a new name.  I saved the file on my local hard drive.
  9. Picked close file option to clear out the characters
  10. Reloaded the new XML file (see step 8)
  11. Loaded just fine
  12. Exited from HCM
  13. Restarted HCM and loaded the XML file
  14. Loaded just fine
  15. Exited HCM

Please try these steps on your machine and let me know how it goes

Share this post


Link to post
Share on other sites

Ok here is what I did to test the problem you reported:

 

  1. Unzipped the three characters.
  2. Opened them in the current version of HD6
  3. Noticed they are 5e characters
  4. Used the 5e Combat Export (sorry about the title being screwy on that)
  5. Loaded the combat export XML file into HCM
  6. Each character was loaded as an NPC
  7. Picked move for each character until I got to Turn 1 Phase 6
  8. Did a Save As and gave the resulting XML file a new name.  I saved the file on my local hard drive.
  9. Picked close file option to clear out the characters
  10. Reloaded the new XML file (see step 8)
  11. Loaded just fine
  12. Exited from HCM
  13. Restarted HCM and loaded the XML file
  14. Loaded just fine
  15. Exited HCM

Please try these steps on your machine and let me know how it goes

Ok...  Here goes.

 

1.  Unzipped the three characters into a new directory on local drive

2.  Opened in HDv6 Build 20160704

     a. Opened Black Guardian

     b. File Menu - Combat Record Export for 5th edition

     c. Closed Character

     d.  Repeat same steps for Boulder and Earth Wind and Fire

3.  Closed HD

4.  Opened HCM 1.0.9

5.  Opened Black Guardian as NPC

6.  Add Boulder as NPC

7.  Add Earth Wind and Fire as NPC

8.  Ran combat attacking each character with one of the others (except poor Boulder...  He never recovered enough to attack)

9.  Ran combat to Top of Turn 1 Phase 8

10.  File Save As combat turn 1  (Did not add .xml to end) -- File did not show up on computer.

11.  File Save As combat turn 1.xml  -- File showed up (Yea!)

12.  Closed file.

13.  Chose Open File

        a.  choose no - do not reset as player / non player

14.  File bombed with same error as before (attaching logs and characters)

15.  File - Exit

16.  Restart program

17.  File Open - Same file (combat turn 1.xml)

18.  File bombed with same error  (attached log file)

 

Just tried something else....  Same steps as above, from 4 on, but did NOT add Earth Wind and Fire.  Ran combat to Turn 1, Segment 3.  Clicked Save not save as.  File saved to LAST loaded .XML file (in this case Boulder.XML)  Looked at file manager and saw this, then Clicked Save As and saved file as try 2 turn 1.XML.  Closed the combat, then reloaded.  It loaded no problem.  I then add Earth wind and fire, complete one more phase of combat, then Save As try 3 turn 1.XML.  Close and attempt to reload.  No go.  Adding those files to the list below.

 

I hope this helps to narrow down the error....

 

Jerry

 

Try two.zip

hcmlogging20160912092306.txt

hcmlogging20160912093249.txt

hcmlogging20160912095452.txt

Boulder.XML

try 2 turn 1.XML

try 3 turn 1.XML

Share this post


Link to post
Share on other sites

Good News:  You are not crazy!  :winkgrin: The original combat records are good.  The combat records which were saved from HCM do have the problem tag in them.

 

Bad News:  I have repeated your steps and I cannot recreate the saved combat record problem either with the installed HCM 1.09 on my machine or running it in the debugger and stopping at the exact spot where the 'tag' is created.  This problem can't happen.  But it is happening for you.

 

Request:

  • Could you completely uninstall HCM and do a reinstall of HCM?
  • When you start HCM go to the Help menu and pick Debug Options.  Make sure Turn Debug On? is on and then set the Debug Level to Trace. 
  • Run all Steps #1 thru 14
  • Send me the log file (it should be much bigger than the previous ones)

Thank you

Share this post


Link to post
Share on other sites

Ok.  Tried what you asked.

 

Uninstalled HCM 1.09

Re-installed HCM 1.09.  Side note on installer, when you tell it to go to a different diretory, it wouldn't 'create' the directory (in this case c:\Hero Combat Manager 1.09  It told me it could not create the directory or something similar.  If I created said directory, it told me that I might be erasing everything in said directory, did I want to do that.  I did, it installed....

 

Debug on, and set to trace.

 

Loaded the three characters, then did a save of the combat file (Try 4 Turn 0.XML) (included with the log file)

Ran through  Turn 1 Segment 4.  Was at the top of 5.

 

Saved file as try 4 turn 1 Segment 5.XML (included with the log file)

 

Closed the combat.

 

Loaded try 4 turn 0.XML -- Loaded no problem

 

Closed the combat.

 

Loaded try 4 turn 1 Segment 5.XML -- would not load.  Same error.

 

try 4 turn 0.XML

try 4 turn 1 Segment 5.XML

hcmlogging20160913083842.txt

Share this post


Link to post
Share on other sites

Good News:  I wasn't able to exactly replicate the defect you found, with the information your provide I was able to look through my code and figure out what could cause the defect.  This revealed a number of other defects that are of the same variety which I am now working on fixing.

 

No bad news...

Share this post


Link to post
Share on other sites

×