Jump to content
sentry0

Weird issue running on a Chromebook

Recommended Posts

I'm running Hero Designer on a Chromebook using Croustini (Debian Stretch) with Oracle Java 13 installed.  I'm seeing a really strange behavior when I launch the app.

 

The first way I launch the app is by using the following command: 

java -Xms32m -Xmx64m -jar HD6.jar

This will run the application but it will be painfully slow and there will be artifacting in the UI.  So I started playing around with my options and I found that if I passed a command line flag after the HD6.jar reference the app boots up and runs (mostly) fine.  It doesn't matter what flag I pass in, it just works.  The app looks slightly different too, the splash screen is even different.

 

This is the command I run when things work with a minimum of issues (there's a slight display issue with file folders, which I can live with):

java -Xms32m -Xmx64m -jar HD6.jar -Ddummy=0

I'm attaching the trace.log in case your curious.

trace.log

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...