Jump to content

Can't launch HD6.jar

Recommended Posts

Ok...a few things:


1. The JDK is the Java development kit - it includes the runtime environment (what you need) plus a bunch of developer tools (which you most likely don’t).  You could install just the JRE (Java runtime environment) by going to www.java.com


2. A statement of “check the console” sounds like you’re trying to run the application from your browser...which you’ve likely realized by now you don’t want to do.  Double click on HD6.jar to launch the app.  If that doesn’t do it (some windows systems don’t like to let Java configure itself for .jar files), google “jarfix” - the first result will contain a small program you can run to correct the file associations on your system.

Link to post
Share on other sites

Alright, I tried downloading JRE, but that didn't seem to get me anywhere. I am using a mac currently, so it doesn't look like jarfix will fix my problem? I'd try to post whatever message it's trying to refer to in the console, but honestly it doesn't look like it has a specific message for the error.

Link to post
Share on other sites

Something's definitely not configured correctly on your system.  


Could be easy:  make sure you have full rights to the directory that you're running HD6.jar from -- it's going to try to create some files and subdirectories there and will error out if it doesn't have access.


If that doesn't work, open up a terminal and post the output from the following:


java -version

You can also try navigating to the directory that you've saved HD6.jar to and manually running the app via the following:


java -jar HD6.jar

At the very least, you should get to see whatever error your system is throwing that way -- post it here and we can work from there.

Link to post
Share on other sites
  • 3 weeks later...

I am having the same problem as alliebgoode. I'm on macOS 10.13.4, using Java 10.0.1 x86_64. I click the icon and it give me the popup error message alliebgoode described above. When I run "java -jar HD6.jar" from the Terminal in /Applications/HERODesigner (which is drwxr-xr-x, user:jhaierr, group:staff), it displays the following errors:


Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/java/swing/plaf/nimbus/NimbusLookAndFeel
	at java.base/java.lang.ClassLoader.defineClass1(Native Method)
	at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1009)
	at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174)
	at java.base/jdk.internal.loader.BuiltinClassLoader.defineClass(BuiltinClassLoader.java:801)
	at java.base/jdk.internal.loader.BuiltinClassLoader.findClassOnClassPathOrNull(BuiltinClassLoader.java:699)
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClassOrNull(BuiltinClassLoader.java:622)
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:580)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
	at com.hero.Launcher.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: com.sun.java.swing.plaf.nimbus.NimbusLookAndFeel
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
	... 10 more

Running java -version yields:

java version "10.0.1" 2018-04-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.1+10)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.1+10, mixed mode)

To view the error messages, I had to install the Java JDK as opposed to merely the JRE.

Link to post
Share on other sites

Just clarify for any future issues that people might have, I first wiped out any old version of Java (e.g., Mac version 6, version 8), and I installed Oracle's Java 10.0.1 JRE, but HD6 does not seem to work under Java 10. So I uninstalled that and got version 8. Now it works.


UPDATE: I also did the same in Windows, and had the same experience.


So for now, it looks like using Java 8 at https://www.java.com is the best answer, whether on Windows or macOS. Don't update to Java 10 for now.

Link to post
Share on other sites

Back from a brief vacation...


Starting with Java 9, Oracle broke the way the UI manager handles some of the look and feels (the appearance of the GUI components). Methods that worked without issue previously started throwing errors.  In particular, the look and feel that HD uses by default was modified.


I just posted an update that _should_ work in all versions of Java (using reflection to determine the proper call to set the look and feel).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...